Versi cPanel terbaru sekarang menawarkan beberapa versi PHP dengan EasyApache 4. EasyApache 4 memiliki dukungan multi-PHP yang mendukung PHP 5.4, PHP 5.5, PHP 5.6, PHP 7.0 PHP 7.1 dan PHP 7.2. Ekstensi MongoDB PHP mendukung semua versi PHP dan dapat diinstal menggunakan alat pecl pada server cPanel.

Pecl tool path berbeda untuk versi PHP yang berbeda. Di bawah ini kita akan melihat cara menginstal ekstensi PHP mongoDB di server untuk versi PHP yang berbeda

Ada dua ekstensi yang berbeda satu disebut mongo yang mendukung dari PHP 5.3 ke PHP 5.6. Satu lagi disebut sebagai mongodb yang didukung oleh PHP 7.0 PHP 7.1 dan PHP 7.2

Install MongoDB PHP extension untuk php 5.5

/opt/cpanel/ea-php55/root/usr/bin/pecl install mongo

Install MongoDB PHP extension untuk php 5.6

/opt/cpanel/ea-php56/root/usr/bin/pecl install mongo

Install MongoDB PHP extension untuk php 7.0

/opt/cpanel/ea-php70/root/usr/bin/pecl install mongodb

Install MongoDB PHP extension untuk php 7.1

/opt/cpanel/ea-php71/root/usr/bin/pecl install mongodb

Install MongoDB PHP extension untuk php 7.2

/opt/cpanel/ea-php72/root/usr/bin/pecl install mongodb